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Working Model Tutorial
by Mark Minor

Thistutorial provides basic information for modeling planar rigid body dynamics using the Working Model 2D
software that was included with your text:

Robert L. Norton, Design of Machinery: An introduction to the Synthesis and Analysis of Mechanisms
and Machines. Second Edition. New York, NY: McGraw-Hill, 1999.

The Working Model 2D software is capable of modeling the motion of rigid bodies that may be connected by a
variety of joints and constraints, and acted on by actuators (motors, cylinders), connectors (springs & dampers), and
environmental effects (gravity, viscous friction, & magnetism). In thistutorial, the basics of modeling with
Working Model 2D will be taught.

1. Installation

The following instructions can be used to install the software on your own computer. To begin, you must have
accessto a PC or MAC with a CD-ROM drive. Installation on the Mechatronics computers is planned, but you will
need to place your disk in the CDROM drive to run the software. Write your name and phone number on your CD
in case you misplace it.

1.1 PC Instructions (MAC installation has not been successful)

1. Pacethe "Design of Machinery" CDROM included with your textbook in the CD drive of your
compulter.

2. Browse the contents of the Disk using Windows Explorer or from "My Computer".

3. Change to the Wminstaller directory.

4. Run the Setup.exe program in that directory (the .exe extension may not be visible, depending on the
configuration of your system).

5. Follow the installation instructions. Use the Serial Number provided during the installation. Recall
that you will probably need to type the last digit of the serial number when prompted.

2. Setting up a model

2.1 Force Fields

Working Model calculates forces resulting from the following customizable force fields, which can be changed
from the World menu.

< Gravity (acting vertically downward in the workspace by default)

< Air resistance (off by default)

< Electrostatics (off by default)

< User specified fields. (off by default)

2.2 Collisions

Collisions between bodies are activated or deactivated by selecting the bodies and choosing Do Not Collide or
Collide from the object menu (on by default)

2.3 Units

Sl units are assumed. Several unit systems can be selected and customized by going to the View menu and
selecting Numbers and Units...
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2.4 Mass and Inertial Properties

Every rigid body created in Working Model has geometric and material characteristics that are used to calculate
mass and inertial properties.

< Geometric properties are changed by graphically dragging or stretching the object or via keyboard by
selecting the object and then choosing the Geometry option from the Window menu.

< Material properties are modified from the Properties form which is opened by double-clicking the
object or from the Properties option from the Window menu. Material properties are pre-defined and
customizable. Propertiesinclude: mass, density, coefficient of friction, elasticity, charge, initial
position and initial velocity

3. Creating Rigid Body Models

Following are basic tools for creating rigid body models of planar systems using Working Model 2D software. See
HELP (by pressing the F1 key) accompanying the Working Model software under the Contents tab and "Working
with Bodies' subject heading for further information.

3.1 Creating Rigid Bodies

Rigid body elements are created using the commands shown on the Rigid Body toolbar, Figure 1. These elements
can be combined using the Rigid Joint, shown below, to create more complex geometry. Hereishow to create a
Rigid Body element:
1. Select one of the buttons on the toolbar, Figure 1.
2. Click in the workspace and drag diagonally.
Circular Bodies ' 3| [
Polygon Bodies = ¢Z|{3| Curved Bodies
Rectangular Bodies =3|.7.] Anchor/Ground Body

Square Bodies

Figure 1. Rigid body toolbar.

3.2 Creating Joint Elements

The following tools are used to define joint properties for rigid bodies. To apply them to a body do the following:
1. Select the joint element from the Joint Element toolbar, Figure 2.
2. Apply the element to the rigid body by clicking the mouse at the desired location.
Point (for pin joints and pin/slot joints) e [ = | Square Point (for fixed joints and keyed slots)
Horizontal Slot | ==| || | Vertical Slot
Curved Slot 4| @] Closed curved Slot

Figure 2. Joint element toolbar.

3.3 Constraining Rigid Body Motion

Two methods may be used to constrain the motion of rigid bodies. Method 1 combines Joint elements to form an
implied constraint between two bodies. Method 2 joins overlapping bodies or joins bodies by explicitly placing a
particular joint at a specified location (not requiring joint elements to be created first.)

3.3.1 Method 1:
Assuming joint elements have been created on each of the bodies to be joined:
1. Select the joint elements to Join by holding the Shift key and clicking the joint elements,

2. Click the 39i€| command from the toolbar and the rigid bodies will align and be joined. The type of
joint created is dependent on the types of Joint elements selected. Two point elements will create a
pinned joint whereas a point and a slot element will create a pin-slot joint.
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3.3.2 Method 2:
Explicitly creating a particular type of joint at a specified location between overlapping bodies or between a body
and ground is accomplished using the commands shown on the toolbar below. Hereis how:
1. Select thejoint from the toolbar, Figure 3.
2. Click the desired location of the joint. If two bodies are overlapping and the joint is placed on them,
the joint will be created between them. If the joint is applied to a single body (no overlap at the joint
location), the joint will couple that body to ground.

Pin Joint | 424|424|| Rigid Joint (binds objects together)
Horizontal Slot Joint  E%|EE|| Keyed Slot Joint (horizontal)
Vertical Slot Joint | [E|| Keyed Slot Joint (vertical)
Curved Slot Joint | @%|i&|| Closed Curve Slot/Slider Joint

Figure 3. Joint toolbar.

4. Editing Rigid Bodies

4.1 Changing the dimensions of a Rigid Body

The dimensions of arigid body can edited graphically by selecting the object and dragging its placeholders (the
little black squares at the four corners of the object), via keyboard by selecting the object and choosing Geometry
from the Window menu, or by sdecting the body and modifying the data shown in status bar at the bottom of the
screen, Figure 4.

“1400 48800 w  WEEE w  wiBsn  m  @lnom
D e—————— |

Figure 4. Changing body properties using the status bar.

4.2 Position and Rotation of UNCONSTRAINED rigid bodies

Position: Select the % tool, click on the object, and drag it.

Rotation: Select the Rotation Tool 21 and drag the body to the desired orientation. Notice that as you position the
mouse over the object, a small symbol will appear that indicates the center of rotation.

4.3 Position and Rotation of CONSTRAINED rigid bodies

Permissible orientations of a constrained body is defined by its constraints. Using the [*  tool and clicking on the
body it is possible to drag it through its possible positions and rotations.

5. Couplers and Drivers

The following couplers and drivers, Figure 5, are similar inusage 02" SPring $:°: Ae|| Translational Spring
to the rigid bodies described above. They are all connected to Rotary Damper iy Transiational Damper
rigid bodies at nodes and have properties, such as compliance or Gear | #|[| | Translational Spring & Damper
force, which can be edited by double clicking on the object. Torque | f& | = |Force
Rotary objects must be place on a pivoting node. Motor | & |==||Actuator
Rope ' a4k || Sepator
Pulley ' @ [—||Rod (binary massless link)

Figure 5. Couplers and Drivers Toolbar.
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6. Building a Four-Bar Linkage
=
1. Select the Rectangl eBody tool. E Fle Edit ‘Wold View Object Define Measwe Scipt Window Help =l@l =l
2. Draw arectangle in the workspace by dlicking one  2I=18] s/ Sle] | »[o|A|LS]] Ruelsoifi]|
corner, dragging the mouse to the opposite corner, g »
and then clicking again: ==
3. Duplicate the Rectangle by picking Duplicate =
from the Edit menu (or by pressing the CTRL and | Luine
D keys smultaneously.) Sl
4. Move the second rectangle directly above the first o=
rectangle. (Click-and drag it) =|ll
5. Draw another rectangle, overlapping the top and £19]
bottom rectangles, Figure 7. ala . 7
6. Duplicate thelast link and move it to the opposite e -
end of the structure, Figure 8. BN
7. Create Pin Joints between the links, Figure 8, by &S
selecting the pin joint tool and clicking in middle £5 e
of the regions where the rectangles overlap (a el
small x will appear when your mouse isin the e
middle). = [
8. Anchor/Ground the bottom link, Figure 8. T T
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Figure 6. Building afourbar linkage. Steps 1-2
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Figure 7. Building afourbar linkage, Steps 3-5.

Figure 8. Building afourbar linkage, Steps 6-7.
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9. You can now move the linkage into different
positions by clicking links and dragging them to a
new location, Figure 9.
Now simulate the linkage by clicking the run
button. It isassumed gravity acts downwards, so
the linkage falls downward and collides with the
bottom link, Figure 10.
< Pressthe STOP button to end the
simulation and RESET to return the
linkage to its initial position.
< To show the intermediate positions shown

below, click one of the Tracking options

(Every 2 Fames) under the World menu.
To alow full motion of the linkage, collisions
must be turned off. Select the objects and then
from the Object menu choose Do not collide.
Simulate the linkage again. Since the linkage is
symmetric (stl=p+q), it isa " Special-case
Grashof" linkage (Class I11). You should see the
double crank, Figure 11, and double rocker,
Figure 11, motionsintermittently, shown below
left and right, correspondingly. Pressthe stop
button after the simulation has run long enough to
exhibit both types of motion (less than 20-30
seconds) and reset the initial condition by clicking
the Reset button.

10.

11.

12.
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Figure 9. Building afourbar linkage. Step 9.
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Figure 10. Building afourbar linkage, Step 10.
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Figure 11. Building afourbar linkage, Step 12, simulation.

Figure 12. Building afourbar linkage, Step 12, simulation.
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13. Turn the linkage into a Grashof mechanism by stretching/shrinking the length of the right vertical link to the
proportions shown in Figure 13. Thisis done by selecting the link and then dragging one of its handles (one of
the four square boxes that appear at the corners of the link when it is selected) to the new dimension.

14. Drive the linkage by placing a motor &l at the node connecting the (short) crank link and the grounded link,
shown in Figure 13.

15. Run the modedl simulation. Y ou should see the crank-rocker behavior shown, Figure 14.
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Figure 13. Building afourbar linkage, Steps 13-14, modified to be Grashoff and mot‘or driven.
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Figure 14. Building afourbar linkage, Step 15, simulation of Grashoff Iinkagé.
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Crank Slider Example

Place a slot on the background, Figure 15, using the slot element
Draw asmall link and use a pin joint A to anchor it to the background, Figure 15.

Draw alonger link, overlapping the end of the small link and use a Pin Joint ﬁltojoin the two links, Figure 16.
Now draw asmall horizontal link, Figure 17, and attach a Square Point Element =] to its middle.
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Figure 15. Crank Slider Example. Steps 1-2. Figure 16. Crank dlider example, Step 3.
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Figure 17. Crank slider example, Step 4.
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5. Select the Square Point Element and Slot Joint simultaneously (hold the shift key) and press %2in®l. Thiswill

6. Now add point elements to the end of link 2 and to link 3, Figure 18.
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Figure 18. Crank dider example, Step 6.
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Figure 19. Crank dider example, Steps 7-12.

Select the point elements and join them. The links will now be joined, Figure 19.
Now add a motor to the short link at the pin joint connected to ground, Figure 19.
Draw a sguare block above link 3, Figure 19. Thiswill be the load that is lifted.

0. Measure the motor torque by selecting the Motor, opening the Measure menu and selecting the Torque

Transmitted option. A small box will appear with measurement information. It can be moved anywhere in the
workspace. Click the arrow inits upper left corner to change it to a graph, or vise-versa.
11. Add asimilar graph for the Y-Position of the block, Figure 19.
12. Now run the simulation. Notice that both graphs are sinusoidal, but 180° out of phase.
13. Change the motor speed (by double clicking on it to open its properties window) to determine at what speed the
Square Block begins to lose contact with link 3. Notice the effect that the loss of position has on the graphs.
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that y=0. Thiswill serve as the ground that your system will jump from.
2. Draw another body (any desired shape) for the robot body and add a vertical slot element

Di|d] &|%(@ S|2] % 3|A[L8]2]| Runs|swon|ies|

pin to 90 degrees (in order to match the vertical slot).

¥t Working Model 2D - [pogodemo.sm]

3. Draw the pogo leg next to the body and add a SQUARE pin element. Be sure to change the angle of the square
ly] File Edt Ward View Object Define Measure Script Window Help

1. Draw arectangular body and anchor it to ground. For convenience, make sure that the vertical position is such
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Select the square pin (again be sure that the angle of
the pin is 90 deg.) and the dot element and click the
“Join” button, Figure 21. bbb
Select the leg and then go to the Object menu and VoW
select Send to Back, .
Now add a spring. Attach one end to the pogo leg
and the other to the body.
Modify the free-length of the spring by selecting

opening the spring's properties menu. Thiswill place
the spring in a deflected initial position that will apply
aforceto the system. F=kx. Figure 24. The “Active
when” setting can also be modified to allow the
spring to only act on the system if some condition
(such ast<.5) exists.

Add any necessary charts. In this case, we will
generate a pot of body height body height. Select
the body and under the Measure menu, select
Position, and then Y-Graph. See Figure 25.

Run the smulation! See Figure 25.

Figure 21. Step 4.

T ' Position of Polygon 4
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Figure 25. Simulation result.
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Figure 22. Step 5.
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Figure 24. Step 7, spring
properties.




